DirectAdmin升级phpMyAdmin版本

时间:12-03-26 栏目:VPS教程 作者:赵 容 评论:7 点击: 9,270 次

phpMyAdmin是一个PHP编写的通过web方式管理和操作MySQL数据库的一个工具,我们熟悉的包括lnmp环境、DA、CP面板均使用它来管理MySQL数据库。但是,安装了DirectAdmin(以下简称DA)的朋友们会发现,DA默认安装的phpMyAdmin版本极低,为phpMyAdmin-2.11.11.3-all-languages,而目前官方最新的版本是3.4.10.1,那么,如何升级phpMyAdmin版本呢?今天赵容部落就来分享DA升级phpMyAdmin的过程。

phpmyadmin

首先,以root用户SSH登陆VPS(或者服务器),按照步骤输入以下代码(本教程以phpMyAdmin-3.4.9为例)。

wget -O /usr/local/directadmin/scripts/packages/phpMyAdmin-3.4.9-all-languages.tar.gz http://dfn.dl.sourceforge.net/sourceforge/phpmyadmin/phpMyAdmin-3.4.9-all-languages.tar.gz

#下载新版本源码
tar xzf /usr/local/directadmin/scripts/packages/phpMyAdmin-3.4.9-all-languages.tar.gz -C /var/www/html

#解压到相应目录
cp -f /var/www/html/phpMyAdmin-3.4.9-all-languages/config.sample.inc.php /var/www/html/phpMyAdmin-3.4.9-all-languages/config.inc.php

#修改配置文件名称
perl -pi -e "s#\['auth_type'\] = 'cookie'#\['auth_type'\] = 'http'#" /var/www/html/phpMyAdmin-3.4.9-all-languages/config.inc.php

perl -pi -e "s#\['extension'\] = 'mysql'#\['extension'\] = 'mysqli'#" /var/www/html/phpMyAdmin-3.4.9-all-languages/config.inc.php

#写入配置
chown -f -R webapps:webapps /var/www/html/phpMyAdmin-3.4.9-all-languages
chmod -f 755 /var/www/html/phpMyAdmin-3.4.9-all-languages
chmod 000 /var/www/html/phpMyAdmin-3.4.9-all-languages/scripts

#以上步骤修改权限
rm -f /var/www/html/phpMyAdmin

#删除原来的快捷方式
ln -s /var/www/html/phpMyAdmin-3.4.9-all-languages /var/www/html/phpMyAdmin

#新建快捷方式

好了,经过上面的操作,您的phpMyAdmin版本已经升级至3.4.9,您可以尝试访问下,一般已经OK了。

神马?403?不能访问?!OK,赵容也遇到过这个奇怪的问题,不同的服务器通过上述过程升级之后,有些直接OK,还有些却不能访问phpMyAdmin管理,报错403。下面是解决方法,输入下面的命令即可。

chown -R webapps:webapps /var/www/html

Oh,还是权限问题,哈~这种情况出现在采用CGI模式的DA上比较常见。好了,phpMyAdmin升级就是这样子了,欢迎大家讨论这个强大的面板其他可能遇到的问题!

香港/美国/国内高速VPS

声明: 博客仅为分享信息绝非推荐,网站不参与交易绝非中介,内容均仅代表个人观点绝非权威,读者请自行考虑后入手并自担风险!一分钱一分货仍是恒久不变之真理,未成年读者(包括生理和心理)请在监护人陪同下访问本站!本文由( 赵 容 )原创编译,转载请保留链接: DirectAdmin升级phpMyAdmin版本鄙视无耻复制行为!
关于隐私: 赵容非全职打理博客,所有评论不保证审核时间进度,我有义务保证您的个人信息不经由赵容部落透露给任何第三方,随意或虚假邮箱评论会自动进入垃圾箱无法展示和给您回应.
关于安全: 任何IDC都有倒闭和跑路的可能,出口线路更不可控,月付和备份是您的最佳选择,请保持良好的、有规则的备份习惯.

DirectAdmin升级phpMyAdmin版本:目前有7 条留言

  1. 学习了~感谢 👿

    2015-12-15 16:33 [回复]
  2. 地板
    缘来:

    大哥救助!今天重装DA的时候,一时手痒图新鲜!自定义编译安装把mysql版本选择了5.6,导致DA面板安装完,内存占用了我400多M,求mysql降低版本的方法啊!不胜感激

    2014-07-17 10:15 [回复]
    • 赵 容:

      这个应该不是你的MySQL版本造成的内存占用多吧?
      不过,400M内存也不多啊

      2014-07-17 10:27 [回复]
      • 缘来:

        是mysql5.6版本占用太高,我排查过!求版本降低方法啊

        2014-07-17 10:30 [回复]
  3. 板凳
    theend:

    这个可以用
    ./build set phpmyadmin_ver XXXXX
    ./build phpmyadmin
    来搞定。。。

    2012-08-23 18:00 [回复]
  4. 沙发
    hostpike:

    貌似直接改DA的配置文件,然后升級DA會自動升級phpmyadmin,而且也不會報錯哦

    2012-03-28 09:10 [回复]
    • 赵 容:

      ~~(╯﹏╰),DA官方论坛也推荐这么升级呢?phpmyadmin不是php版本哦!PHP的版本是直接改下配置文件build下就可以了,这个phpmyadmin我不确定!

      2012-03-28 09:12 [回复]

发表评论


海星云主机

广而告之