LNMP0.8安装ionCube和eAccelerator后显示“不支持”的解决方法

时间:12-04-11 栏目:VPS教程 作者:赵 容 评论:20 点击: 10,643 次

买了VPS之后,赵容喜欢装个军哥的lnmp,即使是闲置,无聊时看看探针也方便。相信很多朋友也在使用这个一键包,比较简单,复制、粘贴,然后就是waiting……不过,昨天有朋友反映,使用最新的lnmp.8,装好ionCube和eAccelerator后,探针依然显示“不支持”,赵容看了下,确实如此,不过,解决的方式不算麻烦,这里分享给大家。

首先,按照教程装完lnmp0.8,然后在lnmp0.8目录下运行./ionCube.sh和./eaccelerator.sh回车安装这两个组件,完成后查看探针,确实显示不支持。奇怪了,我刚明明按照军哥的教程安装的,为什么他会显示不支持呢?管它的,先重启下lnmp看看!

/root/lnmp restart

提示如图:

lnmp0411

有报错,看来有问题!提示貌似是选择相关组件的路径不对?是的,不被支持,是由于相关组件路径问题,PHP5.2.17使用的是ioncube_loader_lin_5.2.so不是5.3,而eaccelerator路径是no-debug-non-zts-20060613 而不是no-debug-non-zts-20090626,明白了原因,修改就简单了。

下载php.ini到本地,或者直接vi /usr/local/php/etc/php.ini修改:

zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.3.so"

修改为  zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.2.so"

zend_extension="/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so"

修改为 zend_extension="/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so"

然后刷新探针,呕耶!终于显示支持咯!希望军哥会修正脚本的这个问题,那时就不用这么麻烦了!

香港/美国/国内高速VPS

声明: 博客仅为分享信息绝非推荐,网站不参与交易绝非中介,内容均仅代表个人观点绝非权威,读者请自行考虑后入手并自担风险!一分钱一分货仍是恒久不变之真理,未成年读者(包括生理和心理)请在监护人陪同下访问本站!本文由( 赵 容 )原创编译,转载请保留链接: LNMP0.8安装ionCube和eAccelerator后显示“不支持”的解决方法鄙视无耻复制行为!
关于隐私: 赵容非全职打理博客,所有评论不保证审核时间进度,我有义务保证您的个人信息不经由赵容部落透露给任何第三方,随意或虚假邮箱评论会自动进入垃圾箱无法展示和给您回应.
关于安全: 任何IDC都有倒闭和跑路的可能,出口线路更不可控,月付和备份是您的最佳选择,请保持良好的、有规则的备份习惯.

LNMP0.8安装ionCube和eAccelerator后显示“不支持”的解决方法:目前有20 条留言

  1. 容哥,问一下lnmp 0.9里面没有这两行怎么办,只看见这个zend_extension=/usr/local/zend/ZendGuardLoader.so

    自己加上去会有事吗?

    2013-05-01 17:08 [回复]
    • 赵 容:

      0.9的话可以无视我这篇文章的啊,因为0.9修正了我这里说的这个问题的,直接安全就OK’

      2013-05-01 17:16 [回复]
      • 可是探针里边看了一下,都是红叉叉,没打开。。。。

        2013-05-01 17:17 [回复]
        • 赵 容:

          ./eaccelerator.sh
          ./ionCube.sh 这些都装了,装了重启下lnmp,应该看到支持的了。

          2013-05-01 17:18 [回复]
          • 科技小玩意儿:

            都安装了,运行几天了,重启n次了,还是几把红叉叉 😥

            2013-05-01 17:19 [回复]
  2. 6楼
    a130301:

    容哥,我只是跑个emlog,装完lnmp后,不需要FTP,“安装其他组件”中哪些是需要装的。

    2012-04-22 22:43 [回复]
    • 赵 容:

      不装都可,但是有些程序需要某些组件的,所以酌情安装。另外,装了这两个组件我觉得有益无害~

      2012-04-23 07:29 [回复]
      • a130301:

        装了其他组件后一般会多用多少内存啊。

        2012-04-23 19:35 [回复]
        • 赵 容:

          几十兆

          2012-04-23 23:43 [回复]
  3. 5楼
    greyboy:

    荣mm

    zend_extension=”/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so”

    zend_extension=”/usr/local/zend/ZendOptimizer.so”

    只有这两个 没有你说的那个

    2012-04-15 15:54 [回复]
    • 赵 容:

      如果按照军哥那边的安装教程,装好了这两个组件,是绝对跟我文章所说一致的哦

      2012-04-15 16:01 [回复]
  4. 4楼
    黄冈网:

    感谢蓉蓉,这个问题好几个月了,eAccelerator缓存插件都是不支持,不管我选择的是old还是new,我还以为是我VPS的问题。

    2012-04-13 10:30 [回复]
    • 赵 容:

      😉 修改下就好咯~!在lnmp0.7版本没这个问题好像~

      2012-04-13 10:31 [回复]
  5. 地板
    小猪:

    /root/lmp restart 这里少个字母啊。容哥。

    2012-04-11 13:38 [回复]
    • 赵 容:

      我晕,真悲剧,哎,一个字一个字的敲,完了没检查就出悲剧了!
      感谢提醒,马上修正!

      2012-04-11 13:39 [回复]
  6. 板凳
    微魔部落:

    呵呵,我之前也遇到这个问题了,直接假装没看见… 😆

    2012-04-11 12:39 [回复]
    • 赵 容:

      这……掩耳盗铃啦,我看到那个支持,开心多了~

      2012-04-11 12:49 [回复]
  7. 沙发
    六森品位:

    L的系统不太好弄,正在入门,先学习了 😉

    2012-04-11 10:21 [回复]
    • 赵 容:

      我倒觉得方便,因为复制、粘贴方便……

      2012-04-11 10:26 [回复]
      • 是啊,特别是新手 ,太多了又记不住,用脚本安装太方便了 😐 😛

        2012-04-11 12:04 [回复]

发表评论


海星云主机

广而告之